Symptom
User performs a keyword and item search using any criteria, but the search is not successful
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Perform a keyword and item search using any criteria
- The search does not provide the correct results or returns zero results and the below error is shown in the UI
"Search Failed. Either the searchers country is not configured or it is not using country picklist "
Cause
Edit Candidate Privacy Options is enabled in provisioning.
Resolution
There are can be multiple causes for this error to appear. Customers should check the following are configured correctly
- On the Succession Data Model configure the user country field as country picklist
- On the Candidate Profile Template, configure the country field as country picklist
- The searcher should have a country value set in their employee profile
- Check the employee export file and ensure that the user has a value in the country column, the value should reflect the option ID of the assigned country
- Go to Manage Data -> Country->Assigned Country of user, and ensure that the country is configured correctly and contains the correct country code(3char), country code(2char) and country code(numeric)
- The en_US label of the country should also match the ISO Country Guidelines.
- Make sure to add the field id definition from the Candidate Profile as a <standard-element-ref refid="field id definiton"> in the data model under the <element-permission type="write">
- Default value for the picklist country should match with the default value for MDF object in Manage Data.
- Make sure to remove all warning while validating the Candidate Profile Template.
See Also
2479642 - Candidate Search Error - Search Failed. Country is not configured or is not in the picklist - Recruiting Management
Keywords
Search Failed, searchers country not configured, country picklist, search, no results, user, country code. , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem