SAP Knowledge Base Article - Public

2810426 - Contract LifeCycleStatusCode Not Available For PDI Changes In SDK

Symptom

You are trying to use a custom OData Service for Contract creation and noted that "LifeCycleStatusCode" fields at Header and Item Level are not available for PDI access in SDK.

Environment

SAP Cloud for Customer

Cause

 "ContractLifeCycleStatusCode" fields are available for read purposes on Root and Item. However, they must not be directly influenced by an arbitrary PDI consumer.

Resolution

As an alternative, you will have to use the following:

The action "ReleaseToActivate" on Root level will do the same as action "Activate" on the UI.

Please observe:

  • "Block", "FlagAsObsolete" and "SetBackInPreparation" are likewise available to influence the life cycle status. As in the UI, performing an action on Root level, in general has an impact on the item status.
  • On Item level, the corresponding actions are currently not released for PDI. This way, In the standard OData Service, the status itself is exposed but it is not directly changed. Internally, there is some special coding in the OData framework which translates the status change to the corresponding action of the Root action.

Keywords

 ContractLifeCycleStatusCode, Field, Missing, Root, Item, PDI, SDK, Contract , KBA , field , pdi , item , missing , contractlifecyclestatuscode , root , sdk , contract , LOD-LE-COP , Contract Processing , How To

Product

SAP Cloud for Customer add-ins all versions