Symptom
User cannot login to the system after the credentials have been created. User gets below error:
"Logon data is not correct; log on again"
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
-
Go to the Login screen
- Enter the credentials
You receive the above-mentioned error.
Cause
The issue occurred because the User ID of the user has a space or the special character # added to it.
This causes inconsistency in the system due to which the password fails, and User gets error while trying to log in.
Resolution
Remove the Space or # from the User ID of the User to fix the issue.
Note: The Space could also be present at the beginning or end of the User ID which is not easily identifiable, you may copy and paste and User ID in the notepad to check.
Keywords
Logon data is not correct; log on again , Can't Login, User credentials not working , KBA , SRD-CC-IAM , Identity & Access Management , Problem