Symptom
When an applicant applies on the career portal with Mobile Apply enabled, some picklists are inaccessible and prevent the candidate from performing a selection.
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors Mobile
Reproducing the Issue
- Go to RMK website;
- Search for a job;
- Choose any job posting and click on Apply Now;
- Create a profile in RCM or use an existing account;
- Select the parent picklist;
- In Job Specific Information you will see the child picklist greyed out.
- It's not possibe to select any value for this child picklist.
Cause
- The career site is using Mobile apply and the affected picklist field is associated to a parent picklist;
- The parent picklist is common on both the Candidate Profile Template and Job Application template, but the child picklist only exists on the Job Application template.
Resolution
When Mobile Apply is enabled, the profile creation and application process are consolidated into a single page. Any common field between the Application Template and Candidate Profile Template will exist in the Profile Information section along with the 13 standard fields. If a parent picklist field is common between Candidate Profile and Application Template, then the child picklist field also should be common between both templates.
As mentioned, the child picklist will exist in the Profile Information section of the combined Candidate Profile and Job Application page. The Candidate Profile permissions specified in CPT will control this field.
For more information refer to the Mobile Apply Field Behavior section of our Recruiting guide.
Keywords
Mobile Apply, Child Picklist, Unable to Select, Profile Information, Job Specific Information, Recruiting, RCM, Application , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , How To