Symptom
You want to set the status of a sales quote to 'Won' or 'Lost' using workflow rules but 'Status' field is not available for Field Update action.
Environment
SAP Cloud for Customer.
Reproducing the Issue
-
Go to Administrator work center.
-
Go to Workflow Rules view.
-
Click on New.
-
Enter the Mandatory fields and select Business Object as 'Sales Quote'.
-
Click on Next and define the relevant conditions as per your requirement.
-
Click on Next.
-
Select the Rule Type as 'Field Update', click on 'Add'.
-
In the Field dropdown 'Status' field is not availbale for selection
Cause
As per the standard system behvior you cannot updated the Status of a Sales Quote directly by workflow (field update).
Resolution
- You can set the "Reason for Rejection" via workflow rules and cancel a quote. A cancelled quote which has previously been submitted will then implicitly also be set to lost. So the status of Sales Quote changes to 'Lost'.
- Setting the status of Sales Quote to 'Won' via workflow is currently not possible.We will plan to enhance this future.
Keywords
Workflow rules , sales quote , KBA , workflow , status , sales quote , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-WKF , Workflow , Problem
Product
SAP Cloud for Customer core applications 1905