Symptom
Our Jam email notifications are being sent out with the sender text in random languages
Environment
SAP Jam Collaboration
Reproducing the Issue
- User updates a group in SAP JAM (ex. wall post)
- Users receive an email of the update
- The sender appears in a random language
Cause
The behavior is working as designed since SAP Jam doesn't support the language localization for the company custom brand name via the "Admin Center | Text Replacement" or "Admin Center | Manage Languages".
Resolution
If you want to change the English "SAP Jam" to "Community", you should have all the other languages specify "Community" for "SAP Jam" and not translate "Community" into just one language; otherwise, the SAP Jam system will not be getting "Community" for the "SAP Jam" reference from the main SuccessFactors system.
Note that there are other labels that by default will re-use the value of "COMMON_JAM". For example, the top navigation menu item for "SAP Jam" in the main SuccessFactors' system's header comes from the following label: COMMON_JAM_TAB=$(COMMON_JAM). If you want that top navigation menu item to say "Community", but with the translations for the various languages, then you can use "Admin Center | Manage Languages" to change the "COMMON_JAM_TAB=$(COMMON_JAM)" to "COMMON_JAM_TAB=Community" for English, "COMMON_JAM_TAB=Comunidad" for Spanish, etc. – while keeping the "COMMON_JAM" the same English value for all languages via "Admin Center | Text Replacement".
Keywords
SAP Jam, email notifications, email sender, email sender localized , KBA , LOD-SF-JAM-EML , Email Notification Issues , Problem