SAP Knowledge Base Article - Public

2811837 - "Cannot delete territory; accounts remain assigned to it"; however no accounts have this territory

Symptom

You want to delete a Territory ABC (ABC stands for the territory name) but you get the error: "Cannot delete territory; accounts remain assigned to it"; however in the Account, you cannot find the Territory ABC.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales workcenter.
  2. Go to the Territories view.
  3. Find the Territory ABC and select it and click Delete.
  4. Error: "Cannot delete territory; accounts remain assigned to it" shows up.
  5. Open the Territory and go to the tab Accounts in Territory; an Account XYZ (XYZ stands for the Account name) is listed here.
  6. Click on the Account XYZ to open it.
  7. Go to the Sales Territories facet.

Result: The Territory ABC is not listed in the Sales Territories section.

Cause

The territory ABC had been added previously to the Dedicated Territories in the Account XYZ; you cannot see it in the Sales Territories facet because the pane Dedicated Territories is hidden in the master layout.

Resolution

Unhide the Dedicated Territories pane via Adaptation Mode and then delete the Territory ABC from the Account XYZ. You will then be able to delete the Territory ABC in the Territories view.

Keywords

territory, account, delete , KBA , LOD-CRM-TM , Territory Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1905