SAP Knowledge Base Article - Public

2811874 - Product Description Missing on Multiple Work Centers

Symptom

You have noticed that on multiple work centers where product information would be displayed as part of documents (e.g. sales orders, service tickets), the same is missing and only the product's ID is shown.

Environment

  •  SAP Cloud for Customer

Cause

The most common cause for this issue is that the product's description has not been maintained in the language with which the user has logged into the system — this means, for example, that if the user logs into the system with language set to Spanish, but no description in the Spanish language has been set for the respective product, the description will be blank in the places where this information should appear.

Resolution

Please maintain the product description for all languages generally selected by your company's business users. You can do so by following the instructions below:

  1. Go to the Products work center.
  2. Access the Product Administration view.
  3. Open the relevant product.
  4. In the product screen, navigate to the Other Languages facet.
    • If the same is not visible, you might have to add through layout adaptation.
  5. Click Add.
  6. In the new row, select the Language in the drop-down field and input the Description.
  7. Repeat for all necessary languages and click Save once done.

To edit multiple products at once, please consider the Update mode of the Data Workbench tool using the Product Other Languages object (more details in the “See Also” section).

See Also

Data Workbench documentation at SAP Help Portal.

Keywords

Product Description Missing, Material Description Missing, Other Languages , KBA , LOD-LE-PRD , Product + Product Category , How To

Product

SAP Cloud for Customer core applications all versions