SAP Knowledge Base Article - Public

2812519 - Concur Expense Integration Error: Access Context Missing for Account

Symptom

  You are unable to get expense reports from Concur due to error message.

Environment

 SAP Business ByDesign.

Reproducing the Issue

  1. Go to General Ledger work center.
  2. Go to Get Concur Documents Run view.
  3. Open the application log of the relevant run.
  4. Go to Results tab and expand the list.

Errors:

  • 'Access context missing for account <technical user ID>, please run access grant procedure'
  • 'Technical Response: Service URL / Path PROCESS_DATA'
  • 'Connection to Concur system could not be established.'

Similar error can be achieved with following steps:

  1. Go to Application and User Management work center.
  2. Go to User Registration for OAUTH2 Web Services view.
  3. Check both OAUTH and OAUTH2. One of them have the registered users in red.
  4. Click Ping Service.

Similar access context error is raised.

Cause

There are different reasons why this error may be raised. In this case, both client registrations CONCUR_INTEGRATION_OAUTH and CONCUR_INTEGRATION_OAUTH2 have the same client ID, which should not be the case.

Resolution

Revise all the parameters for both OAUTH service providers.

For further details and steps, you may refer to the SAP Business ByDesign and Concur Integration Guide in chapter 2.3.3 Register Client for OAUTH Web Services

To access the most recent version of the integration guide, follow below steps:

  1. Access https://help.sap.com
  2. In the search field, type SAP Business ByDesign and Concur Integration Guide

Keywords

Concur, Expense Report, Register Client, OAUTH Web Services. , KBA , AP-INT-GEN , Reuse parts of the DU Integration Orchestration , How To

Product

SAP Business ByDesign 1905 ; SAP Business ByDesign 1908 ; SAP Business ByDesign 1911