SAP Knowledge Base Article - Public

2812642 - Receiving Error: "You have indicated that the information provided does not reflect your citizenship status." in Orientation Step with US I-9 Feature [Compliance] - Onboarding 1.0

Symptom

An error message is shown in Orientation Step (3rd Step) with below text.

The following fields are required and must be filled in before you continue:

- You have indicated that the information provided does not reflect your citizenship status. Either change the citizenship status to the correct one and then answer "Yes" to the question, or change your answer from "No" to "Yes".

 

Visual Reference:

SAPSUPPORT-00000 08-03-2019 6.59.59 PM.png

Environment

SAP SuccessFactors Onboarding 1.0 - All Versions

Cause

MA_I91_CorrectStatement is set to No or empty value

Resolution

For Live Customer(s)

In New Employee Step of Form I-9 Employee Information and Attestation (Panel Name(Federal_I9)), the key MA_I91_CorrectStatement is auto-populated with a value of Yes which gives the system idea that new hire entered the information with his/her own knowledge.

There are scenarios where the data key is missing or have an empty value and it will trigger a message to corporate representative in Orientation Step "You have indicated that the information provided does not reflect your citizenship status."; the only way to resolve it is by manually adding the value "Yes" and this can be done by Support at the back end.

If you experience the said message in on of your new hires, please contact support and follow the template below.

 

Contact SAP SuccessFactors Cloud Product Support

Please reach out to SAP SuccessFactors Cloud Product Support in SAP One Support Launchpad via SAP Expert Chat or Support case. In addition, follow the template when creating an case and provide the needed information below.

  • Subject: KBA 2812642 - MA_I91_CorrectStatement Key Correction
  • Component: LOD-SF-OBD-I9

Problem Description:

  1. BizX Company ID 
    • [Insert affected instance]
  1. Affected Hire/Candidate
    • [Insert affected hire/candidate's name]
    • [Insert screenshot of the issue]
  1. Permission to correct the value of MA_I91_CorrectStatement key
    • [Insert approval]
  1. Username for Support Access (Read the agreement below)
    • [Insert Username]
  • May we have your approval for accessing your system environment to continue request? (Reply with your confirmation and username to access, refer to KBA listed below)
  • With your approval, accessing your system environment you agree for the actions we will take below.
    1. Review the data of affected users and compare it to those users who are working as expected.
    2. Capture screenshots/record screen clips of the issue.
    3. Analyze your system configuration
  • To know how to grant support access to SAP Cloud Product Support, please read the full article on 'How to Grant Support Access to SuccessFactors Support Staff' by clicking the reference KBA 2088892.

Keywords

MA_I91_CorrectStatement,  Federal_I9, Form I-9 Employee Information and Attestation , KBA , LOD-SF-OBD-PAN , Panels, Panel Designer , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions