SAP Knowledge Base Article - Public

2812823 - Refresh Status Information - Completed with warning - Full List

Symptom

Instance refresh completes successfully using the Instance Refresh tool however refresh status information shows completed with warnings.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Go to Admin Center
  2. Go to Instance Refresh
  3. Status shows as "Completed with warning"

warnings.png

Cause

These warnings are Displayed when any of below warning occur as listed under the resolution. The warnings do not effect the successful status completion of the refresh and can be resolved by following the steps outlined in 1-9 depending on which message you have encountered.

Resolution

See list of Warnings below:

  1. There are traces of audit logs in the target instance from the source instance after refresh is complete.
  • These logs might appear in your audit reports and the target instance will function as expected. Download the error log file and contact SAP Cloud Support with the log file under component LOD-SF-PLT-IRT 
  1. The User Sync process from HCM Suite to Learning failed. This might cause user data inconsistencies between HCM Suite and Learning. 
  • Please check Employee Export job for error code within provisioning. A common reason for this job to fail post refresh is that the job owner will get restored in the target instance post refresh which means if the job owner no longer exists in the Newly refreshed instance the job will fail with "Invalid job owner this is outlined on the KBA 2791468 - Instance Refresh Tool & FAQ Symptom
  • Another reason is that User Connector-SF in target LMS tenant was not enabled prior to Instance Refresh.  You can ignore the warning message and run User Connector-SF manually after the refresh. Next time if you want the users to be in sync right after the refresh, please have the User Connector - SF enabled prior to the refresh.
  1. The user export job cannot be found.
  • This Warning message could represent three main things:
    1. The job is not existing in the target pre-refresh
    2. The job was not submitted
    3. The job owner set for the export job is not existing in the target instance
  • The workaround is to create a new Employee Export Job, and to this please engage partner or contact SAP Cloud Support under component LOD-SF-PLT-IRT with the information described on KBA 2812823
  • If you are not using Employee Export to sync your users from bizX to LMS, you can disregard this warning message.

    Other possible root-cause if above 3 points do not apply:
    1. Upgrade/migrate triggers the checktool job to run checks or execute self healings. These jobs are failing because the user is somehow unknown. In case the job fail, it is not a big issue. Our jobs are triggered on a daily basis and executes a subset of check almost every day. As the jobs after migrate break, the corresponding checks will be executed a bit later. (Note: This should be confirmed and checked with engineering team)
      If verified, you can ignore the warning as it will not cause any issues. No action is required from your end.
  1. Data anonymization is incomplete.
  • Some of the fields with personally identifiable information might exist in the target instance without being masked after the refresh completed. There is no action required here this is an informational message only. 
  1. Rebuilding of indexes which is required for efficient searches.  
  • This can slow down your search. Download the error log file and contact SAP Cloud Support with the log file under component LOD-SF-PLT-IRT
  1. E-mail masking failed.
  • Masking the internal users with provided input parameter are successful, while creating the refresh request fails. This failure can result in sending emails to real users with reference to test job executions. Download the error log file and contact SAP Cloud Support with the log file under component LOD-SF-PLT-IRT
  1. Data Replication Configuration” data was modified.  The value in “Replication Target System” field was replaced with a dummy value
  • You don’t have to report this information to SAP Cloud Support. To solve the issue, go to "Manage Data"-> "Data replication Configuration" and set the relevant value in “Replication Target System” field. For more information, see Knowledge Based Article KBA 2813109 in SAP ONE Support Launchpad. If you have any further questions kindly contact SAP Support under component LOD-SF-INT-PAY.

  1. Payroll System Configuration data is modified.
  • Empty values were maintained in “Payroll System URL”, “Payroll System Client ID” and “SAP System Configuration” fields. You don’t have to report this information to SAP Cloud Support. To solve the issue, please go to "Manage Data"-> "Payroll System Configuration" and set the status field to “Active”. Afterwards, maintain the relevant value in “Payroll System URL”, “Payroll System Client ID” and “SAP System Configuration” fields. For more information, see Knowledge Based Article KBA 2813109 in SAP ONE Support Launchpad. If you have any further questions kindly contact SAP Support under component LOD-SF-INT-PAY.

  1. Payroll System Assignment” data is modified. The value in “SAP System Configuration” field was replaced with a dummy value.
  • You don’t have to report this information to SAP Cloud Support. To solve the issue, go to "Manage Data"-> "Payroll System Assignment" and set the relevant value in “SAP System Configuration” field. For more information, see Knowledge Based Article KBA 2813109 in SAP ONE Support Launchpad. If you have any further questions kindly contact SAP Support under component LOD-SF-INT-PAY.

   10. USER_MANAGEMENT_SCHEDULE_FIND_USER_SYNC_JOB_ERROR

  • Instance Refresh was completed with warning. Refresh log shows Error Code :- USER_MANAGEMENT_SCHEDULE_FIND_USER_SYNC_JOB_ERROR , Error Message :- The user export job cannot be found. Please contact your implementation partner or SAP Cloud Support to create a new job in Provisioning.
  • The issue is that the User Sync job was not there in the target. As a workaround, the customer should login to the TARGET provisioning and schedule a user export job, which will take care of the user sync from BizX to LMS. 

   11. Latest homepage refresh has the following status: Failed.

  • You can still log into the refreshed target instance and proceed with your planned activities. Meanwhile, please contact Product Support to get this issue fixed. Download the error log file and contact SAP Cloud Support with the log file under component LOD-SF-PLT-IRT.

   12. The reset of avatar data on target instance have the following status: {0}. This activity is to avoid inconsistencies in the avatar data

  • This warning means that the Dynamic Teams avatar data might be broken on the target instance. But it does not constitute a failure of the refresh and can be safely ignored. The workaround is to reupload the avatar images for the dynamic teams on the target instance.

For a complete List of status types in instance refresh see SAP Help Link Here

Keywords

Completed with Warnings , completed with warning , Instance refresh tool , instance refresh , indexes fail , masking , fails , audit logs , warning , warnings , KBA , LOD-SF-PLT-IRT , Instance Refresh Tool , Problem

Product

SAP SuccessFactors HXM Suite all versions