SAP Knowledge Base Article - Public

2813032 - SLA for Holiday Calendars Days Not Working

Symptom

SLA (Service Level Agreements) milestones are not working for holidays, even after you added the holidays to Working Calendar.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ABC (ABC represents the ticket ID).
  4. The holiday was not taken into consideration in the SLA dates determined.

Cause

This occurs when special holidays are added to the Holiday Calendar but not to the Working Calendar itself (Working Calendar is linked to the Holiday Calendar). This leads to unexpected SLA milestone calculation, providing a result date which is a holiday.

Resolution

Manually refresh the existing Working Calendar. To do this, please follow the steps from the blog post: SLA milestone calculation affected due to new holiday introduced

See Also

Blog: SLA milestone calculation affected due to new holiday introduced

Keywords

SLA; Holiday; Calendar; Ticket; Service Level Agreements; Milestone; Date; custom calendar ; custom holiday , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-CAL , Calendar Control , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions