SAP Knowledge Base Article - Public

2813038 - Contacts Syncing From Outlook to SAP Cloud For Customer

Symptom

In the Sync Settings of your Server Side Integration Profile configuration you set up Contacts synchronization filter to "Do Not Synchronize".

do_not_sync_contact.png

However the Contacts kept syncing from Microsoft Outlook to SAP Cloud For Customer.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP Cloud For Customer

Cause

The Synchronization Filter is unidirectional working from SAP Cloud For Customer to Microsoft Outlook only.

Resolution

The filter will only prevent the contacts synchronizing from SAP Cloud For Customer towards Outlook. If you wish contacts not to synchronize both ways there are other things to take care of:

A - The SAP Contacts folder in Microsoft Outlook

sap_contacts_folder.png

When you enable the server side integration with Outlook for an user, a SAP Contacts folder is automatically created in Outlook.

If contacts are created or moved within this folder they will trigger the sharing criteria and synchronization will push them to SAP Cloud For Customer.

You should also be careful with third-party software that might move Contacts to different folders.

B - The SAP Cloud For Customer category

custom_category.png

There are also the custom categories created by the server side integration.

If you select a contact from any folder (not only the SAP Contacts folder) and categorize it, this will also trigger the sharing criteria and the contact will be pushed to SAP Cloud For Customer.

C - The "Keep SAP Contacts Read-Only" option

contact_keep_readonly.png

If you want to avoid completely the synchronization of Contacts from Microsoft Outlook to SAP Cloud For Customer, the best way to do that would be to check the option "Keep SAP Contacts Read-Only".

This option will disable the sync, but will also remove all contacts that you have stored in the SAP Contacts folder. Before enabling it, make sure you don't have Contacts that you wish to maintain there.

D - Set up according to your business scenario

It is important to note that there's no correct way to use those suggestions. You also don't need to use all of them at once.

The recommendation is to understand your business requirements and use your options to match that.

For example if you want to completely disable synchronization both ways you should follow the suggestions above, but you may also want to leave the option for your users to synchronize contacts when desired.

Keywords

Syncing; Synchronizing; Synchronization; Synched; Synchronized; Outlook; Groupware; Server Side; Add-In; Add-On; , KBA , sync , server side , LOD-CRM-GW-SRV , Server side groupware intergration , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions