Symptom
When you try to define the Restriction Rule 99, system takes longer time to process your action which may result in a time out error or system is unresponsive.
Environment
SAP Cloud for Customer
SAP Business ByDesign
Reproducing the Issue
- Go to Administrator work center.
- Select Business Role option.
- Edit a Business Role.
- Go to Access Restriction facet.
- Select the Customers row.
- Define a rule.
- Select Restriction Rule 99.
Cause
This is a known issue with Restriction Rule 99. This occurs when there are lots of access groups belong to the selected access context code. System gives performance issues or eventually a time out error while creating the hierarchy among these access groups.
Resolution
Calculation rule 99 which is a freestyle definition of restrictions is only a fall back functionality, having business roles with fixed restrictions will defeat the complete purpose of business roles, which were supposed to be more dynamic, calculate / determine restrictions based on user's properties of the sales unit to which they belong to.
So, provide authorization (by using other restriction rule, other than 99) to user based on business role using existing restriction calculation rule.
If existing restriction calculation rules do not cater to the needs of business use case, we kindly request you to post this query in the forum SAP Customer Influence.
You can also go through the following SAP Blog: Access Control Management: Access restrictions explained – Restriction Rules
Keywords
restriction rule 99, busines role, rule time out, performance , KBA , restriction rule 99 , unresponsive , SRD-CC-IAM , Identity & Access Management , Problem