SAP Knowledge Base Article - Public

2813102 - Cross domain report: Columns missing on changing alias name

Symptom

Columns, under 'Edit Columns', in Ad Hoc report disappear when the 'Domain Name' is changed in 'General Info' tab.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Create a cross domain report with any domain.
  2. Complete the report definition and save it.
  3. Now, edit the report and in General Info pill section, edit the alias name for the domain and save the report from the same page.
  4. Move back to report listing page and edit that report, again.
  5. Move to the Column pill section.
    Though you see the columns in 'Rearrange Columns', they will not be seen under 'Edit Columns' of the domain for which the alias name is changed.

Cause

The alias name provided while initially creating the cross domain report is considered for further edits. Changing the same, will lead to the issue.

Resolution

  • Under Rearrange columns, you will see the column names are displayed as <domain/alias name>:<column name>
  • Change the alias name in general info pill with the <domain/alias name> present in column pill's 'Rearrange columns' section.
  • Now save the report.
  • Go to report listing page.
  • When you next edit the report, you will see the columns listed under 'Edit Columns' section.

Keywords

ad, hoc, missing, columns, cross, domain, report, alias, name, rearrange, edit, rename , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem

Product

SAP SuccessFactors HCM suite all versions