SAP Knowledge Base Article - Public

2813743 - What to Consider When Replicating Workforce Persons Using New Integration Channels in SAP S/4HANA Cloud

Symptom

This note is relevant when you move from the Manage Workforce app or SOAP API (Replicate Basic Master Data for Workforce from External HR Systems) to Core HR with SAP SuccessFactors Employee Central (‏JB1‏) or to the SAP Master Data Integration service for replicating workforce persons in an SAP S/4HANA Cloud system.

You have activated the workforce person integration channels (JB1 or SAP Master Data Integration service) and use them to replicate the existing workforce persons. After the initial replication, duplicate personnel numbers or new employee business partners are created for the same work assignment or duplicate employee business partners are created for the same workforce person in the SAP S/4HANA Cloud system.

Environment

  • SAP S/4 HANA Cloud 
  • SAP SuccessFactors Employee Central

Cause

  1. Duplicate workforce assignment IDs or personnel numbers are created when, for example, the external person ID (PERSON_ID_EXTERNAL) in the Manage Workforce app and the Person ID in SAP SuccessFactors Employee Central mapping are not consistent across different channels.
  2. Duplicate personnel numbers or new employee business partners are created for the same work assignment or duplicate employee business partners are created for the same workforce person in the SAP S/4HANA Cloud system. 

Resolution

Before proceeding with the points described in this Knowledge Base Article, please read the set-up instructions of the scope item Core HR with SAP SuccessFactors Employee Central (‏JB1‏)Regarding the management of existing workforce persons in your SAP S/4HANA Cloud system, SAP SuccessFactors Employee Central will be the source of the data you migrate to SAP S/4HANA Cloud.

The Manage Workforce app provides an external person ID (PERSON_ID_EXTERNAL). When the customer has moved from Manage Workforce to SAP SuccessFactors Employee Central, make sure that the PersonExternalID, which was used earlier during the upload is the same as Person ID/User ID that is used in SAP SuccessFactors Employee Central. You must ensure that a new personnel number or additional employment is not created in the SAP S/4HANA Cloud system.

NOTE:

Once the workforce person is replicated from SAP SuccessFactors Employee Central to SAP S/4HANA Cloud, the same data should not be updated again through other channels. In addition to this, when switching to other channels, the complete historical data of the workforce person should be carried forward to the new channel.

For example, If you have maintained data in an external system for 3 years, and if you are switching to SF EC, you should enter all this data again.

Manage Workforce app

SAP SuccessFactors Employee Central

PersonExternalID (in Employee template spreadsheet)

Person ID

PersonExternalID (in Employment template spreadsheet)

User ID

UserName

User Name

 

SOAP API

SAP SuccessFactors Employee Central

PersonExternalID

Person ID

PersonWorkAgreementExternalID

User ID

User Name

User Name

 

Manage Workforce

SOAP API

PersonExternalID (in Employee template spreadsheet)

PersonExternalID

PersonExternalID (in Employment template spreadsheet)

PersonWorkAgreementExternalID

In Manage Workforce and SOAP API, the field names for the assignment ID are PersonExternalID and PersonWorkAgreementExternalID respectively.

The Person IDNameCompany Code, BusinessPartnerRole (corresponding to the Employee/Contingent Worker), Country/Region, and Employment Dates must be identical across different channels. Note that if there is any difference with respect to any field, the system does not recognize the existing workforce person and generates a new one or a new personnel number for the same workforce person. Ensure that the UserAlias/UserName is in uppercase. Any further actions, such as global transfers, must not be performed until the workforce person has been replicated.

Once replication using JB1 is active, the workforce persons are replicated using SAP SuccessFactors Employee Central and cannot be uploaded again with the Manage Workforce app. You cannot use the methods Manage Workforce and SAP SuccessFactors Employee Central (JB1) at the same time.

Note that the user responsible for the replication process needs to have the business role BR_ADMINISTRATOR_HRINFO.

Precautions to take when updating business partners after workforce person replication is activated via any of the channels:

  • Do not remove employee (BUP003), employment (BUP010), contingent worker (BBP005), and external employment (BUP011) roles. You should also not change the validity of roles from the business partner.
  • Do not change or remove identification types HCM001, HCM032, HCM033 IDs from the business partner. Do not reassign these IDs to any other business partner.
  • Do not remove HCM001HCM032HCM033 relationship types from business partner.

See Also

  • 2555311 - FAQ - Manage Workforce app
  • 2646803 - How to maintain employees data in an S/4HANA Cloud
  • 2655576 - FAQ: SAP S/4HANA Cloud integration with SFSF EC

Keywords

JB1, SAP SuccessFactors Employee Central, EC, SAP S/4HANA Cloud, PersonExternalID, Replication, Integration, Manage Workforce, SOAP API , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , LOD-SF-INT , Integrations , CA-HR-S4 , Cross-Application HCM Objects in S/4HANA , CA-GTF-BUM , Business User Management , CA-GTF-INT , SAP S/4HANA Integration Content , LOD-EC-INT , EC Integration with ERP On Premise , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions