Symptom
You created a profile in the server side integration and in the Add-In Settings you added Account ID as a field to a given object (e.g. Contact, Task, Visit, etc.).
When creating an object on the side panel in Outlook, the Account field is not displayed.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to E-mail Integration Work Center.
- Go to Groupware Settings.
- Click on the Profiles tab.
- Enter the desired profile to edit it.
- Go to Add-In Settings tab.
- On the desired object (e.g. Contact) in Detailed View tab add the Account ID field in "+ Add Field to Detailed View" link.
- Go to Basic View tab.
- Select the Account ID to be displayed in one of the four available dropdowns.
- Open Outlook with an user that has the same profile assigned.
- On the Add-In side panel click on the Create New button "+".
- Select Contact.
- The Accound field won't be available there.
Cause
Account ID can't be used on create.
Resolution
Navigate to:
- Go to Groupware Settings within E-mail Integration Work Center.
- Go to the Profiles tab.
- Go to Add-In Settings tab.
- Select Detailed View tab of an object (e.g. Contact).
If you expand Account ID properties in the Detailed View of an object you will notice that Account ID doesn't have the property "Display on Create" enabled and is blocked to be changed.
If you wish to add the Account field to the creation of objects you must use the field Account (Reference) instead.
The Account (Reference) field will have the property "Display on Create" enabled by default, so just adding it in the Detailed View of an object should be enough to make it appear during object creation.
Keywords
Groupware; Server Side Integration; Outlook; Account; , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To