Symptom
When trying to access Onboarding either there is an error "Please enable cookies in your browser and try again" or the Onboading dashboard keeps only loading
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding - All Versions
Reproducing the Issue
- Login to the Instance
- From the main menu, click on On/Offboarding
- You will see the error below or the page will keep only loading:
Cause
Browser cache issue or third-party cookies being blocked by the customer's web browser
Resolution
Both error might be caused by a browser issue/setting and can be resolved by following the below steps.
- Browser cache issue:
Open the browser and clear their browser's cookies & cache:
For Microsoft Internet Explorer (IE)
- Tools > Internet Options > Delete Temporary Internet Files
- Tools > Internet Options > Delete Cookies
For Mozilla Firefox
- Tools > Options > Privacy > Show Cookies button > Remove All Cookies
For Google Chrome
- From the “Menu” Menu Button in the upper-right corner of the Chrome window, choose “More Tools” > “Clear browsing data…“.
- Or Press “CTRL” + “Shift” + “Delete” in Windows or Linux, or “Command” + “Shift” + “Delete” on Mac OS X on your keyboard.
- Select “Menu” > “Settings” > “Show advanced settings…” > “Clear browsing data…“.
- Select the period of time you wish to delete cached information using the “Obliterate the following items from” drop down menu. From there, you can choose “Cached images and files“
- Select the “Clear browsing data” button, and Chrome will clear your cache.
- Third-party cookies being blocked by the customer's web browser
For Google Chrome:
- Navigate to Settings
- Site Settings
- Cookies
- Check whether Block Third-party cookies is enabled or not
For Microsoft Internet Explorer (IE)
- Navigate to Internet Options
- Privacy
- Advanced
- Check whether Third-party cookies are Accepted or Blocked
For Mozilla Firefox:
- Navigate to Firefox settings
- Privacy & Security
- Content Blocking
- Check whether Strick option is select or not
Once these steps are completed have user:
- Close ALL browser windows
- Reopen and login to the application
- Repeat steps where error previously occurred
Keywords
browser, browsers, internet explorer, chrome, firefox, cache, cookie, cookies, third-party, third, party, session, sso , KBA , LOD-SF-OBD-SYS , System Performance, Usability, Errors, Security , Problem