SAP Knowledge Base Article - Public

2814490 - Application error when Initiating Background Check with Hireright - Recruiting Management

Symptom

When attempting to initiate Background Check with HireRight, an application error is thrown by the system with the fingerprint 9bda2dd93eb8ed246e44f77073f01d09be09cc0c

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Access Recruiting;
  2. Go to a Requisition where you have candidates pending Background Check;
  3. On the background check status, select a candidate and attempt to initiate it;
  4. Receive an Application Error with the fingerprint 9bda2dd93eb8ed246e44f77073f01d09be09cc0c

Cause

This is caused by some change on Integration Center that is not aligned into the entity.

Resolution

Perform an OData API Metadata Refresh on the instance and try to initiate background check again.

If you have questions on how to perform a metadata refresh, check the article 2171588 - OData API Metadata Refresh and Export - SuccessFactors

See Also

2171588 - OData API Metadata Refresh and Export - SuccessFactors

Keywords

9bda2dd93eb8ed246e44f77073f01d09be09cc0c, background, check, initiate, hireright, application, error , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem

Product

SAP SuccessFactors Recruiting all versions