SAP Knowledge Base Article - Public

2814845 - New users are not forced to change the initial password sent through welcome email after answering the security question

Symptom

New users are not prompted to change the initial password sent through welcome email after answering the security question correctly.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  • 'Admin Tools' > 'Company Settings' > 'Password & Login Policy Settings'> 'Enable Forgot Password feature' > 'Reset Passwords using security questions account through the system' is enabled. This option should redirect users to the security question page to reset their password after answering the security questions correctly.

  • "Welcome Message Notification with Reset Password Support" is turned on and a new user is imported through employee import with the "send new user welcome email" option ticked.

  • The user clicks on the link received in the welcome email and after answering the security question correctly, the user is not asked to change the password and is able to login successfully using the initial password in the welcome email.

Cause

  • "Hide the Personal Password Tab from users" is enabled under "Company System and Logo Settings".
  •  If this is enabled, it will prevent users from being prompted to reset their password.

Resolution

  • Go to "Company System and Logo Settings"
  • Uncheck the "Hide the Personal Password Tab from users" option and save.

See Also

 https://launchpad.support.sap.com/#/notes/2420640 - Passwords: Configuring Password & Login Policy Settings - SuccessFactors Platform

Keywords

password change, password reset, security question, Hide the Personal Password Tab from users, new user login, welcome email, initial password, splunk warning User password needs to be updated , KBA , LOD-SF-PLT-NOT , Email Notifications , LOD-SF-PLT-PWD , Password Policy Settings & Reset Password , Problem

Product

SAP SuccessFactors HCM Core 1905 ; SAP SuccessFactors Platform 1905