SAP Knowledge Base Article - Public

2814851 - Candidate/Application Email Correspondence/Offer Letter not Anonymized - Recruiting Management

Symptom

A candidate or application has been anonymized, emails and/or offer letters are still visible to recruiters.

Environment

SAP SuccessFactors Recruiting Management

Cause

At the time of candidate/applicaiton anonymization, the following settings were not enabled in Admin Center -> Manage Recruiting Settings -> DRM and DRTM Purge Settings -> Deletion of Correspondence

  1. Delete all the Email and print correspondence available for candidate.
  2. Delete all the offer letters available for candidate

Resolution

This is expected behavior, if the above settings were not enabled at the time of anonymization then Candidate/Application Email Correspondence/Offer Letter will never be anonymized. As the Candidate/Application is already anonymized, it is not possible to anonymize this data as a Candidate/Application cannot be purged for a second time. It is also not possible to delete the Email Correspondence/Offer Letter via Odata API. This issue could have been avoided if Deletion of Correspondence settings were considered during product implementation.

See Also

2269680 - Deleting Email, Offer Letter, etc from Candidate Profile While Deleting or Purging

Keywords

Email Correspondence. Offer Letter, Manage recruiting settings, Deletion of Correspondence, anonymize, purge, delete, candidate, application, GDPR , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions