Symptom
This Knowledge-Base Article has been created to address the unavailability (via API / Data Dictionary) of newly created field(s) within Background Element(s).
- You have added a new field to a Background Element via Manage Business Configurations
- When attempting to access this field via API (ODATA / SFAPI), it is not available
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SuccessFactors BizX
- ODATA API / SFAPI
Reproducing the Issue
To reproduce this issue, perform the below steps:
- Create a new field within a Background Element (e.g. Background_InsideWorkExperience)
- Once created, you perform use a GET API request to query / read the data in this Background Element
- You observe that he newly added field is not returned in the response payload from API
Cause
The field is not returned by the API, within the response payload, for the following reasons:
- The newly created field is hidden from / not exposed to the API
Resolution
To resolve this issue, please follow the below steps:
- Access Manage Business Configurations > Employee Profile > Background Elements > Choose the affected Background Element(s)
- Locate the field which is having issue (i.e. not exposed to API) > Click 'Details'
- Ensure the 'Hidden' property is set to 'No'
(if Hidden property is not set to 'No' the field will not be available to the API)
- Refresh the OData API Metadata - Metadata Refresh
After following the above outlines steps within Resolution section, the newly created field should be available within the Data Dictionary and exposed to API.
See Also
SAP SuccessFactors HCM Suite OData API: Reference Guide (Section 10.8 - Background) for additional information on Employee Profile Background Elements
Keywords
Manage Business Configurations, Background Element, ODATA API, SFAPI, Hidden, Visibility , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem