Symptom
You want to use an OData service to load or to retrieve ticket data. This way, you want to access or edit the party roles that you can find in the Involved Parties tab of a ticket, like e.g. the End Customer role. But this is not possible.
Environment
SAP Cloud for Customer
Cause
The system works as designed. The current standard OData services like ServiceRequestCollection don't allow to access or edit the party roles. However, in the future, OData shall be enhanced with a separate service request party entity, containing the party collection. This functionality is planned to be available with release 1911 at the earliest.
Resolution
As a workaround, you may create a custom OData service.
Keywords
fill, specific partner functions, enable, service request, missing, available, , KBA , LOD-CRM-SRP , Service Request Processing , Problem