Symptom
When the customer try to select the date in the calendar tool in the Portlet at People Profile, the system provides an error.
- An application error occurred. Check the console log for more details.
Environment
SAP SuccessFactors Employee Profile (All Versions)
Reproducing the Issue
- Open the Configure People Profile > Select the Live Profile Background Information Portlet > Choose the Background Element in the dropdown > Save
- Go to My Employee File > Search the portlet and click in the Pencil to edit the data
- Click in ADD… > Write the data name > Click in the Calendar Tool and select a date in the past.
- Click in Save and See the error occurring.
Cause
In data model should have some error in the max-leght (max-length="x") in the code to the Date.
Resolution
If you are working with a Implementation Partner, please ask them to follow the steps bellow.
If you don't have a Implementation Partner working with you, please open an case to LOD-SF-EP-JPB to solve the issue in your data model.
Provide all the information bellow:
- Portlet occuring the error;
- Support Access to the instance that you're experiencing the error.
In Provisioning:
- Open the Provisioning;
- Search Data Model Import/Export;
- Export the Data Model;
- Open the Data Model with Notepad++;
- Found the Background Element in the Data Model;
- Edit the max-length="x" to max-length="128";
- Save the document in Notepad++ and Import again in Provisioning;
- Re-open the instance and repeate the process to add date in the portlet;
- The data in the portlet will be successfully saved.
Keywords
background, element, job profile builder, data, model, employee, profile, successfactors, date, error, aplication, tool, calendar, max-leght, select, EDU-14415, LOD-SF-EP , KBA , LOD-SF-EP-BGD , Background Elements , LOD-SF-EP , People Profile , Problem