Symptom
You have scheduled a job to send e-mail reminders of pending time approvals to managers and/or time administrators, but the e-mails being sent are not in the user's preferred language (i.e. e-mails in German for users with language set as English).
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Time Administration work center.
- Under Common Tasks, access the Reminders for Time Approvals view.
- If there are no reminders available, click New Reminder.
- Input the relevant information in the creation pop-up and click Ok.
- Now, select a reminder in the list and click Schedule Reminder.
- Set up one of the scheduling options available, then click Save and Close.
- Once the job runs as scheduled, e-mail reminders will be sent to the relevant parties.
- Checking the e-mail's body, you can see that the language does not match the recipient's language.
Cause
The language of the e-mail reminder is not defined according to the recipients, but is rather according to the user who scheduled the run. The language configuration can be checked using the following steps:
- Log into the system with the credentials of the user which created the reminder run.
- At the top-right corner, click on the user's icon.
- Select My Settings.
- In the Regional Settings tab, you can find the Language field.
Resolution
Please create a new reminder run with a user whose defined language settings match the language of the users targeted for receiving e-mail reminders of time approvals.
Keywords
Reminders for Time Approvals, Language, E-Mail Reminder, Schedule Run, Time Administration , KBA , SRD-HR-TLM , Time and Labour Management , How To