Symptom
- Fail to logon to an SAP System.
- In Crystal Reports, when refreshing a report based off an SAP BW System, or SAP ERP System, it fails with the error:
"Logon failed.
Details: SNC name of the partner system not in ACL system"
Environment
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
- SAP BW 7.4
- SAP BW 7.5
Reproducing the Issue
- In Crystal Reports, open a report based off an SAP System that uses SNC to authenticate the user.
- When refreshing the report, it fails with the error:
"Logon failed.
Details: SNC name of the partner system not in ACL system"
Cause
- The SNC Partner Name information stored in the report were incorrect.
Resolution
- Update the SNC Partner Name information stored on the report:
- In Crystal Reports, open the report.
- Under the menu "Database", select "Set Datasource Location..."
- In the "Set Datasource Location" window, under "Current Data Source", expand the "Properties" of the connection.
- Select "SNC_PARTNERNAME", and click on "F2" on your keyboard to edit the information.
- Enter the correct SNC Partner Information. ( Consult your SAP BASIS Administrator to obtain the correct SNC Partner Information. )
- Once completed, you will be prompted to login to the system.
- Once the login is successful to the SAP System, it will bring you back to the Set Datasource Location windows. Click "Close" to accept the change.
- Save the report.
- Note: Also verify the entry of the SAP System the report connects to, in the SAP Logon, to ensure it is accurate as well.
Keywords
CR , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , BI-BIP-AUT , Authentication, ActiveDirectory, LDAP, SSO, Vintela , Problem
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016