SAP Knowledge Base Article - Public

2816751 - Cannot Filter by Service Category Field in Reports or Data Sources

Symptom

When reporting, if you apply filter criteria for field Service Category in report selection, no report results are retrieved.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Business Analytics work center.
  2. Go to the Design Reports view.
  3. Find and open report XYZ (XYZ represents the report name).
  4. In report selection, open the value help for field Service Category.
  5. Select any valid entry and click OK.
  6. Update the report results.
  7. No results are displayed in report.

Cause

The Service Category field is an UUID compound field and hence selecting and filtering value on this field is not supported.

Resolution

Please use the characteristic field 'Service Category ID' to fulfill your requirement.

See Also

Note that if you have several service categories with the same name or ID, the "Service Category ID" field will only show 1 ID. IDs should ideally be unique so that the identification of a particular record can work. If you have a setup where the same ID needs to be used twice, you can add the fields "Version", "Valid From" and "Valid To" via the Add Fields feature in the report. Alternatively, if you are using a custom data source, you also can add the fields directly to your data source, by adding the data source "Service Category Name".

Keywords

Service Category; Cannot filter; Service Category filter; Service Category report; report category filter; , KBA , service category , cannot filter , service category filter , service category report , report category filter , LOD-LE-CSM-SIC-ANA , Service Issue Category Analytics , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Product Enhancement

Product

SAP Cloud for Customer add-ins all versions