SAP Knowledge Base Article - Public

2816789 - The Status of Account Changes to Obsolete After the Customer Merge

Symptom

An account status change from active to obsolete after merge is completed .

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Go to the Data Cleansing work center.
  2. Go to the Customer Merge view.
  3. Click on the New button, which opens the New Customer Merge screen.
  4. Select the check box as Account .
  5. Under field First Customer select XYZ1 (where XYZ1 represent customer name with status active) and under field Second Customer select XYZ2(where XYZ2 represent another customer name with status active).
  6. Click on Save and Open button.
  7. In the new customer merge which open go to Attribute Selection facet.
  8. Select the account XYZ1 as master account and click on action Initiate Merge.
  9. Once the merge status is completed, you can see the master account i.e. XYZ1 is consider as surviving account and will remain in status active.
  10. If you open another account i.e. XYZ2, the status is change from active to obsolete.

Cause

After customer merge, an account which is not the surviving account will have status change to obsolete as it is no more needed.

Resolution

Changing the status of non-surviving account to obsolete after merge is an expected system behavior.

Keywords

Surviving Account , Surviving Record , Obsolete status , KBA , customer merge , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions