SAP Knowledge Base Article - Public

2817348 - Thank you for applying email not received by candidate

Symptom

  • Candidates report that they did not receive the "Thank you for applying" email
  • "Thank you for applying" email was sent to a different email address than the candidates’ one
  • When checking in the Application History of the affected candidate, no changes can be seen in relation to primary email address field

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Open Job application of a candidate
  2. Go to Correspondence portlet
  3. Check email “Thank you for applying” sent by the system related to the application
  4. Recipient’s email address appears to be incorrect

Cause

There is a discrepancy between the candidate’s email address in the header of the application and the email used in the Correspondence Portlet because of the following sequence of events:

  • Candidate applies to a job requisition
  • In the application form the email is changed from EMAIL1 to EMAIL2 - (Possibly because of autofill feature of the browser or because of a human mistake)
  • Application is sent
  • Email “Thank you for applying” is sent from the system to EMAIL2 as per application form, instead of to EMAIL1
  • The candidate profile is changed because the candidate noticed that EMAIL2 is incorrect and changed it back to EMAIL1
  • The application detail page is opened by an operator. This will trigger the creation of the snapshot - KBA 2081624 - Edit Candidate Profile Snapshot - Recruiting Management
  • When the snapshot is created, data from the candidate profile is synchronized back to the application form, overwriting EMAIL2 with EMAIL1 because this was changed in the candidate profile

Therefore the email is sent to EMAIL2 despite the candidate’s details in the header of the application showing EMAIL1 instead.

The same behavior applies to candidate’s first name and last name.

Resolution

It is recommended to advise candidates to avoid enabling autofill browser plug-ins. However, should they choose to, then we suggest that they double check that all the content they have entered is correct before submitting the application.

Keywords

Thank you for applying email, Trigger email, Candidate Snapshot, Email sent to wrong recipient, Email not received, Autofill , KBA , LOD-SF-RCM-POD , Home Page, Pods and Portlets, To Do List , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions