Symptom
You are trying to create a new ticket from an account and received an error as below
Error: Retrieving Currency Details from Configuration not Possible
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customer workcenter
- Go to Accounts view
- Select Show All and find for ABC (where ABC is the id of the account)
- Navigate to Tickets facet
- Select New
You are receiving an error as mentioned below
Error: Retrieving Currency Details from Configuration not Possible
Cause
You have not maintained a valid currency which needs to be determined for the allowed currencies in the business configuration activity.
Resolution
Currency for a transactional document is determined in the following order
- The currency will be copied from the account’s sales data if it exists.
- If step 1 fails, system checks on the currency maintained in the org. model for the corresponding sales organization.
- If step 1 and step 2 fail, currency is derived from the company (Seller party) in the sales quote.
- If the above 3 steps did not yield the currency, then if Ticket is pricing relevant, the Currency is pre-filled as EUR.
Additionally for the currency to be used, user has to ensure that the currency is maintained and allowed in the below configuration. All currencies are predefined according to ISO code list 4217.
- Go to Business Configuration workcenter
- Go to Implementation Projects view
- Select the relevant implementation project and open Activity List
- Select Show all Activities
- Select Fine-Tune tab
- Search for Activity Currencies
- Ensure that it is added to the project
- Open the Currencies Activity
- Currency Code XYZ (where XYZ represents the currency code), should be maintained here
User has to ensure that this currency code maintained here is not blocked. Blocked currency codes will not appear in the currency list of the business transactional documents and master data, causing the error.
Keywords
Currencies, Missing, Error, Currency Details, Configuration, Not possible, Invalid Currency , KBA , LOD-CRM-SRP , Service Request Processing , Problem