Symptom
- Is it possible to set Employee Status field in the Job Information section of an employee's profile through a Business Rule?
- How are employee statuses set for each employee?
- The field Employee Status is a read-only field and cannot be modified.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Configure Business Rules tool
- Create New Basic Rule with Job Information Object as base object
- Try to configure Business Rule to Set 'Employee Status'
- Error is triggered that Employee Status value is read-only and cannot be modified
Cause
This is expected behavior.
Resolution
- The field Employee Status‘ in Job Info, is set to read-only in ‘Configure Business Rules’ because the values for this field are determined automatically by the system and it is important that this value remain consistent at all times.
- The Employee Status is set based on the Event Reason which is selected/determined when Job Info data is changed. This should allow for a high level of flexibility.
Keywords
SF, Success Factors, EC , KBA , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions