Symptom
Fields are greyed out while trying to make it visible via Fiori Adaptation
Environment
SAP Cloud for Customer
Reproducing the Issue
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Log in to Fiori client.
- Enter Adaptations mode.
- Open any TI , for example Tickets.
- Click the Edit icon on the header.
- You will see few fields for example Type, Subject are greyed out and cannot make it visible.
Cause
Personalize option for the fields are not enabled
Resolution
-
Go to Tickets.
-
Open a ticket.
-
Go to Adaptation mode.
-
Click the pencil icon just in the header section.
-
Now in the right panel you will see 2 options , header and General information.
-
Click the arrow next to "General Information".
-
You will see the fields Type, Subject etc.
-
You will see that the field subject that you want to add is greyed out. Click the arrow next to subject and enable the option "Personalize".
-
Now you will see another option called Hide available , uncheck that and you will the field subject in the header.
Keywords
Fiori Adaptation, field greyed out in adaptation, unhide fields , KBA , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , Problem
Product
SAP Cloud for Customer core applications all versions