SAP Knowledge Base Article - Public

2818401 - SMS Integration Failing - Recruiting Management

Symptom

The candidate or the operators are getting this error in the Candidate Profile:

  • " Connection to mobile gateway failed. SMS selection may not be current. Please revisit this page later  to verify. "

Environment

SAP SuccessFactors Recruiting Management - All Versions

Reproducing the Issue

  1. In Career Site, Profile Information
  2. Fill all the required information and enable "Send me SMS notification"
  3. The error appears:

Note: Connection to mobile gateway failed. SMS selection may not be current. Please revisit this page later to verify.

Cause

There are 2 possible causes:

1. The credentials and/or the URL aren't properly filled.
2. The Candidate Opt-in SMS trigger is not enabled.

Resolution

Here are the resolution based on the cause.

For cause 1, here are the steps to correct the issue:1
1.Go to Admin Center
2. Manage Recruiting Settings
3. Short Message Service (SMS)
4. Verify that the credentials and URL are correct. Double check any space accidentally saved at the end of the information or if there are any lower/upper case in the wrong character.

For cause 2, Here are the steps.

1. Go to Manage Recruiting Email Templates.
2. Create a new template. Enable the SMS Status and fill out SMS Body then save the template
3. Go to Manage Recruiting Trigger
4. Enable the Candidate Opt-in SMS trigger and link the new template created.

See Also

2336022 - How to Enable SMS Interview Notifications - Recruiting Management

Keywords

SMS Integration Candidate Profile gateway error; Connection to mobile gateway failed. SMS selection may not be current. Please revisit this page later to verify.; SMS Error; , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem

Product

SAP SuccessFactors Recruiting all versions