SAP Knowledge Base Article - Public

2818957 - An Error as Enter a Valid Number is Trigger in Ticket Item

Symptom

On editing the price value under ticket's item facet in fiori client an error Enter a Valid Number is trigger.

Environment

SAP Cloud for Customer .

Reproducing the Issue

  1. Logon in your system using Fiori Client.
  2. Go to the Service work center.
  3. Go to the Tickets view.
  4. Search for ticket LMN (where LMN represents the ticket id) and open it.
  5. Go to the Items facet and click on the edit button.
  6. Change the price value from XX.YY to XX,YY (where XX and YY represents the numberic value) and click on the save button.

An error Enter a Valid Number is trigger.

Cause

You are chaging the format, which is not matching your company setting.

Resolution

  1. Logon in Fiori Client.
  2. Go to the Company Setting->My Setting.
  3. Here go to Regional Setting tab.
  4. Here, under the Decimal Notation you need to change your format accordingly, if you need to XX,YY instead of XX.YY.
  5. Save the Changes.

Keywords

My Setting , Ticket Item Price , Regional Setting , KBA , decimal notation , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins 1905 ; SAP Cloud for Customer add-ins 1908 ; SAP Cloud for Customer add-ins 1911 ; SAP Cloud for Customer core applications all versions