SAP Knowledge Base Article - Public

2819212 - Outdated or Unsupported Browser Message Appears in a Mashup on Cloud for Customer Mobile Application

Symptom

You have a mashup to show an external website embbeded in a Cloud for Customer screen. It works fine when accessing the system via browser, however when accessing the system via mobile app you receive the warning message: "You are using an outdated or unsupported browser and may experience some problems."

Environment

SAP Cloud for Customer

Cause

The site which is being loaded has a validation to check the browser compatibility based in the user agent (browser name identifier). The C4C app use the embeded web-view of the mobile device, however the user agent name is the name of the app and not the name of the browser (iOS Safari, Chrome, ...).

Resolution

If you would like to avoid this kind of warning message you should ask to site developer include the Cloud for Customer user agent identifier "Cloud4CustEx"in the list of compatible browsers.

Keywords

URL Mashup; HTML Mashup; Cloud for Customer Extended App; C4C Mobile app , KBA , c4c mobile app , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , AP-RC-GEN-MSH , Mashups , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1905