SAP Knowledge Base Article - Public

2819356 - Lead Data are overwritten after associating a Contact to a Lead

Symptom

You have maintained data like mobile number and Marketing Permissions in a Lead, but after associating the Lead to an existing Account+Contact, theis data has disappeared.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales workcenter.
  2. Go to the Leads view.
  3. Create a new Lead without Account and maintain the mobile number and the Marketing Permissions.
  4. Click Actions > Associate to Account and Contact.
  5. Select the relevant Account and Contact and Save.

Result: in the new Lead, the mobile number and the Marketing Permissions have disappeared; further the Marketing Permissions facet is gone from the Lead TI altogether.

Cause

The existing Contact did not have the mobile number and marketing permissions maintained. When associating the Lead, the fields get overwritten by the data maintained in the Contact. Please note the Marketing Permissions facet is only available in a Lead without Account.

Resolution

In order for the data to be available in the Contact and in the Lead after associating the Contact, please maintain them in the Contact itself.

  1. Go to the Customer workcenter.
  2. Go to the Contacts view.
  3. Open the relevant Contact.
  4. Click Edit and maintain the mobile number and the Marketing Permissions.
  5. Then you can associate the Lead without data loss.

Note: Marketing Permissions are available in the Contacts TI.

Keywords

lead, contact, data, associate , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1905