SAP Knowledge Base Article - Public

2819852 - Not all fields are displayed in the header section

Symptom

You have enabled the "Show Header Details on the Top in Fiori Client" option in the company settings of your system.

You open a BO, for example an account, you notice that the header section does not contain all the expected fields.

The header section before the "Show Header Details on the Top in Fiori Client" option was enabled showed more information.

Environment

SAP Cloud for Customer 1908 and after

Reproducing the Issue

  1. Open the system as an administrator.
  2. Under the user icon in the top right corner select 'Settings'.
  3. Open the 'Company Settings' tab.
  4. Find and check the "Show Header Details on the Top in Fiori Client" option.
  5. Click Save.
  6. Log off and back on to the system to apply changes.
  7. Open a workcenter, in this example Customer workcenter -> Accounts view.
  8. Open any account.

You notice that not all the information that was previously visible in the previous header view is visible in the new header now.

Cause

The fields that are missing are contained in an embedded component which is not supported in the new header display.

Resolution

Disable the "Show Header Details on the Top in Fiori Client" by the following steps:

  1. Open the system as an administrator.
  2. Under the user icon in the top right corner select 'Settings'.
  3. Open the 'Company Settings' tab.
  4. Find and uncheck the "Show Header Details on the Top in Fiori Client" option.
  5. Click save.
  6. Log off and back on to the system to apply changes.

This will revert to the standard header view and all fields will now be visible under the overview tab of the BO.

Keywords

Show Header Details on the Top in Fiori Client, missing fields , embedded component, header. , KBA , pdi , ec , embedded component , AP-RC-MOB-UIF , Responsive UI , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions