SAP Knowledge Base Article - Public

2819863 - Value of the Customer Reference ( PurchaseOrderByCustomer ) field is Not Returned in The Sales Volume App(s)

Symptom

Value of the Customer Reference (PurchaseOrderByCustomer) field is Not Returned in The Sales Volume App(s)

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open a Sales Volume App e.g. Sales Volume - Flexible Analyses
  2. Add the "Customer Reference" field
  3. Result shows "#"

Cause

Adding this filed in the standard system would impact performance

Resolution

It is possible to define a custom query that considers the field PurchaseOrderByCustomer (label: Customer Reference) from the sales document. 

  1. Open the “Custom CDS Views”App
  2. Create and publish a custom CDS view based on I_BillinDocumentItem.
  3. For this view, select relevant Billing Document item fields, and relevant Billing Document header fields.
  4. Add also I_BillingDocumentItem._SalesDocument.PurchaseOrderByCustomer and add also billing document header field I_BillingDocumentItem._BillingDocument.BillingDocumentIsTemporary.
  5. Define a filter as part of this CDS view: " I_BillingDocumentItem._BillingDocument.BillingDocumentIsTemporary != 'X' " (without this filter, draft billing documents would also be considered, which should be avoided).
  6. Now that the Custom View has been created open the "Custom Analytical Queries" App and create a custom query.
  7. As data the source, choose the custom CDS view created in steps 1-5.
  8. Define the query to suit the business requirement.
  9. The Customer Reference (PurchaseOrderByCustomer) can be used.

 

Keywords

Flexible Analyses, Detailed Analyses, Customer Reference, PurchaseOrderByCustomer, Sales Volume , KBA , SD-BIL , Billing , SD-FIO-HBA , Analytical Apps , Problem

Product

SAP S/4HANA Cloud Public Edition all versions