Symptom
When employee opt-out Benefit is not able to change effective date
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors Employee Central
- Global Benefits
Reproducing the Issue
- Go to Employee Profile
- Access Benefits section
- Opt-out Benefit
- System triggers message "You are opting out of Medical Bill Claim effective from Date" and not allow date change
Cause
Expected system behavior. Benefit Opt-out was designed to be effective on current effective date.
Resolution
System will just allow user to opt-out from benefit into current effective date.
From b1908 employees will be able to edit Opt-out date. An employee can opt out of an auto-enrolled benefit and re-enroll into the same as per their eligibility and as per the enrollment schedule. Also, the auto-enrollment job will skip the employees that have opted out for the entire period. When employee clicks now on Opt out button, the pop up shows the Opt out Effective from date. This Effective from date field is editable if the configuration in the Benefit is enabled as editable effective from date.
Keywords
opt out benefit date effective change , KBA , LOD-SF-EC-GBF , Global Benefits , Problem