SAP Knowledge Base Article - Public

2820887 - Marketing Consent is not Considered in Check Addressability for Target Groups

Symptom

  • You create a target group and expect that the Check Addressability button will check for the marketing consent of added members.
  • The channel specific marketing consent is not considered.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Marketing workcenter.
  2. Select the Target Groups view.
  3. Open any target group.
  4. Click Check Addressability - select any option.

Check addressability does not consider channel specific marketing consent options set up in master data.

The general Contact Permission entry is considered.

Cause

  • Check addressability function checks for correctly maintained addresses for the respective channel and the general Contact Permission.
  • The marketing consent for specific channels can only be used as a filter option for selecting members in target groups.

Resolution

  1. Navigate to the Marketing workcenter.
  2. Select the Target Groups view.
  3. Open any target group.
  4. Click Maintain Members.
  5. Filter for Channel Permission.
  6. Add members with filtered channel permissions.

Keywords

Marketing, Campaign, Target Group, Marketing Consent, Kampagne, Zielgruppe, Marketing-Einwilligung , KBA , AP-CPG-TG , Target Group , Problem

Product

SAP Business ByDesign 1905 ; SAP Business ByDesign 1908 ; SAP Business ByDesign 1911