SAP Knowledge Base Article - Public

2821066 - Workflow for Sales Document is not working as expected in SAP S/4HANA Cloud Public Edition

Symptom

Workflow for sales document is not triggered as expected.

"Image/data in this document is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

 SAP S/4HANA Cloud Public Edition

Cause

  1. Open the Manage Workflows app.
  2. Locate and select the respective workflow from the list.
  3. Check if the workflow name is displayed.
  4. If there is a message indicating that the workflow definition is based on a previous version, the issue is confirmed.

CMW.JPG

Resolution

For each each workflow name, follow the steps below:

  1. Select the workflow and click "Copy". 
  2. Delete the original workflow (not the copied one).
  3. Rename the copied workflow to the original name.

This process ensures that the workflow is recreated with the latest definition.

Keywords

SAP S/4HANA Cloud Public Edition, Public Cloud, Sales document workflow, credit memo workflow, credit memo requests, quotation workflow, workflows not triggering, issue with workflow, workflow definition, approval workflow, previous version workflow, Manage Workflows app, workflow troubleshooting, this definition is based on a previous version , KBA , SD-SLS , Sales , SD-SLS-2CL , Sales (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions