Symptom
You select a View from the Toolbar (for example, Extensibility Explorer) but nothing happens.
Environment
- SAP Cloud Application Studio
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
- Log in to the Cloud Application Studio.
- Open the UI Designer (In the Toolbar, select Administration > Open UI Designer).
- In the UI Designer Toolbar, select View > Extensibility Explorer.
Cause
This issue is caused when the View is not 'Docked' but instead it is 'Floating' elsewhere. This View then can be 'Floating' off-screen if you sometimes work using multiple monitors. These settings are saved in a file called DockPanel.config on your local machine.
Resolution
You need to delete or rename the file DockPanel.config. Once it is deleted or renamed, the UI Designer will reset the settings to default on launch. A new DockPanel.config will also be created when the UI Designer is closed. In order to do so, please proceed as follows:
- Close the UI Designer and Cloud Application Studio.
- Open the File Explorer on your local machine.
- Follow this Path: C:\Users\XYZ\AppData\Local\SAP\UIDesigner (where XYZ is your User).
- Delete or rename the file DockPanel.config
Keywords
Configuration, Explorer, Extensibility, Toolbox, Properties, BO Browser/Data, Model, Property, Document Outline, CheckMate, Check, Results, Where Used, List, Output Window, Version History, OBN, Dock, Panel, DockPanel, Float, Floating, Docked, Multiple, Monitor, Off-screen, Settings, File, SDK, PDI, Cloud Application, Studio, , KBA , AP-RC-BDS-INS , ByDesign Studio Installer , Problem