SAP Knowledge Base Article - Public

2821611 - Country Code Area from the Phone Number Field Cannot be Edited - Recruiting Management

Symptom

  • Country Code special area in Phone Number field is greyd out and can't be edited.
  • Is there a way to remove the gray area/country code information from the Phone Number field?
  • Try to save the profile and you will see this error: Your Work Has Not Been Saved! Please correct the marked fields below and there are no fields marked

External Candidate Profile:

2019-07-30_14-09-22.png

Internal Candidate Profile:

2019-07-30_14-20-09.png

Error message:

007.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management - All Versions

Reproducing the Issue

  • External Candidate Profile
  1. Login in the external career site
  2. Go to Profile Information
  3. Check the Phone Field
  • Internal Candidate Profile
  1. Go to Careers
  2. My Candidate Profile
  3. Check the Phone Field

Cause

The standard field id="cellPhone" will have the country code area if Short Message Service (SMS) functionality is enabled (and its relevant field added to the candidate template = optInCellNumber)
To populate this special area, you must configure the standard field id="phoneCountryCode". Then when selecting the country information, the country code will be automatically populated inside the code area in the Phone field and if the field id="phoneCountryCode" is not configured, the field can't be populated manually.

Keep in mind that according to product design, the fields optInCellNumber and phoneCountryCode, must be granted the same permission (either both as read or both as write).
This will prevent the error message, but if you give "write" permission, it will be possible to edit the Send me SMS Notification option as well.

2019-07-30_14-31-02.png

2019-07-30_14-22-13.png

Resolution

With Short Message Service (SMS) enabled, the country code area will only be populated by the country code field, therefore the field should be configured if you would like to have the functionality.

Product Management is working on improving the error message which might be a bit misleading on what the actual issue is.

See Also

2802316 - Candidate Profile "phoneCountryCode" field is not visible

2336022 - How to Enable SMS Interview Notifications

Keywords

Country Code Area; Country Code Field; Country Code Greyed Out; Your Work Has Not Been Saved! Please correct the marked fields below, optInCellNumber, phoneCountryCode , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem

Product

SAP SuccessFactors Recruiting all versions