SAP Knowledge Base Article - Public

2822472 - Instructions on How to use a BADI to Manage the Communication Actions in E-Mail

Symptom

This document explains that you can use the available Badi option to enable or disable all reply options such as ( Reply, Forward, or Reply with Outlook ) for e-mail, as well as the list of the BADI exists for the Tickets scenario and your correspondent functionalities.

Environment

SAP Cloud for Customer

Cause

To achieve these settings you will need to enhance the standard C4C using a BADI via the SDK software.

Resolution

The BADI below is the one that must be activated to use this feature

BADI.png

The following BADI exists for the Tickets scenario:

Enhancement Spot

BAdI

Use Case

ES_COD_MANAGE_AWS_FEATURES

COD_MANAGE_AWS_FEATURES

You can disable the reply/new option for interactions

You can default the "To" address for New e-mails only

ES_COD_SMAP_RESTRICT_FROM

COD_BADI_SMAP_RESTRICT_FROM

You can filter the channels available in the "From" modal dialogue

ES_EMAIL_OUT

BADI_EMAIL_OUT_SUB_SUFFIX

You can adjust the subject of the e-mail before it is sent out

DISABLE_FEEDER_SEND

You can disable the "Send" button for replies via e-mails, SMS or portal

See Also

https://blogs.sap.com/2020/08/05/implementing-custom-badi-in-c4c-in-order-to-restrict-list-of-from-channel-providers

Keywords

BADI; E-mail; Communication; Interaction;COD_MANAGE_AWS_FEATURES; COD_BADI_SMAP_RESTRICT_FRO; BADI_EMAIL_OUT_SUB_SUFFIX; DISABLE_FEEDER_SEND , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions