Symptom
You have a Product Category Description in your system and want to add a new description in a different language. However, Data Workbench does not export the External Key that is mandatory to update the values.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Data workbench work center
- Select on Export
- Search for Product Category Description
- Export the data
- Select on Monitor
- Open task name XXXX (where XXXX refers to Product_Category_Task_Name)
- External Key is blank
- Select Import
- Search for Product Category Description
- Upload the target entity (product category description)
- Select Next
- Go to Monitor view
- Open the relevant error file
- Error: External key does not exist for Product Categories
Cause
A Data Workbench export file does not include External Keys. This is the standard behavior.
Resolution
Follow the workaround below:
- Extract the existing descriptions by exporting Product Category Description via Data Workbench
- In the extracted CSV, sort the records according to the content of ParentObjectID (= UUID of the product category) column
- Ensure that the data in the ParentObjectID column shows an ascending order
- Empty (not remove) the column ObjectID and HeaderObjectID
- Maintain a new External_Key for the records
- Maintain the data in Language and Product_Category_Description
- Ensure that only ParentObjectID, External_Key, Product_Category_ID, Language and Product_Category_Description are maintained
This CSV/Excel file can be used to update the required data:
- Go to Import view
- Select Individual Object tab
- Select Update option on object Product Category Description
- Complete the Upload of the file and the Import steps
Keywords
Data Workbench, Update Product category Description, Languages , KBA , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , Problem
Product
SAP Cloud for Customer core applications all versions