Symptom
You are trying to use an Employee/Service Agent as the Ship-To address of a Sales Order document, however, when adding the user ABC (ABC represents the ID of the Employee/Service Agent), you face the error: Country in address of Ship-To party missing.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select New Sales Orders from the Common Tasks.
- Enter an account ID.
- Enter the user ABC as the Ship-To.
- Error: Country in address of Ship-To party missing.
Cause
The reason you are facing this error, is because the address under the Service Agent was not correctly maintained for line In-House Address.
Resolution
This is the system expected behavior.
- Go to the Business Partner Data work center.
- Select the Service Agents view.
- Search for the user ABC.
- Click Edit.
- Select Addresses.
- Select the In-House Address line.
- Maintain the expected address for the user.
After maintained the correct information you should not receive the error anymore.
Keywords
Address; Ship-To; Service Agent; Business Partner Data; Sales Order , KBA , AP-SLO-SO , Sales Order , How To