Symptom
You have implemented the CTI BAdI to handle the inbound calls i.e. enhancement option "CTICallWrap-upActions", but the BAdI is not getting triggered in Fiori Client.
Environment
SAP Cloud for Customer
Cause
BAdI - CTICallWrap-upActions. This enhancement cannot be used in Fiori Client.
Resolution
The Live Activity in HTML5 UI and Fiori Client are designed differently. In Fiori Client, the suggested approach of updating the custom fields is to use the outports
In terms of the solution you will not miss any functionality here. However, it is a different way of implementation to update the custom fields.
The Call WrapUp BAdI used to give flexibility to update a business activity’s fields using the call’s IVR parameters. In Fiori UI, you can still do that using the public outports by creating an Embedded Component and binding it with one of the public outports. You need to fire an event when the Embedded Component’s inport is invoked and in this event you can update the custom Business Object.
Also please note that, there is no plan to introduce the BAdI in Fiori design as it will be a duplicated functionality.
Keywords
CTI, Badi, Call, wrap up, action, fiori, RUI, live activity , KBA , cti, badi, call, wrap up, action, fiori, , LOD-CRM-LA , Live Activity , Problem