Symptom
The action Request External Pricing is not available in Tickets.
Environment
SAP Cloud for Customer - Service
Reproducing the Issue
-
Go to the Service work center.
-
Select the Tickets view.
-
Select Ticket 123 (123 represents the Ticket ID).
-
Select the Actions button.
The action Request External Pricing is not available.
Cause
There is a field labeled as Pricing Status in the Pricing section of Ticket UI. If the pricing was already calculated once for the items added to the ticket, then this field is set to Calculated Successfully and the action Request External Pricing is disabled.
However the next time the agent makes any changes to the Ticket (e.g. add a new Item or modify existing item’s quantity / date) or change the Sales area data (e.g. Distribution channel, Division code etc.) then the Pricing status value changes to Not Calculated, which means that the Pricing needs to be re-triggered and hence the action gets enabled in the UI.
Resolution
This is the standard system behaviour.
Keywords
Request External Pricing Not available Inactive Greyed out Grayed Inactive , KBA , LOD-CRM-SRP , Service Request Processing , Problem