SAP Knowledge Base Article - Public

2824028 - Error "Field cannot be created. Business context capacity is exhausted" when creating a new custom field

Symptom

Error Field cannot be created. Business context capacity is exhausted occurs when creating a new custom field in Custom field and logic app.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open app "Custom field and logic".
  2. Click button to create a new custom field.
  3. Enter required fields and select business context, eg. Sales: Billing Document Item.
  4. Click the button "Create"
  5. Error "Field cannot be created. Business context capacity is exhausted" appears.

Cause

The capacity to add extension fields to data base tables or business contexts, respectively, is limited due to DDIC and data base limitations. Therefore, each application maintains quotas in the extensibility registry for the number of fields and characters which can be added to a business context. For example, for business context: Sales: Billing Document / Sales: Billing Document Item and Sales: Sales Document / Sales: Sales Document Item, quota is defined as below:

Maximum Fields: 170
Maximum Capacity (e.g. number of characters): 1,700

Note: Of the 1700, 60% are available for custom fields. Therefore, 1020 characters are available for the creation of custom fields.

Resolution

To continue creating new custom fields or enable usage for custom fields, you can delete unused custom fields to release the quota. When adding new fields, there is a bar "Business context capacity" which shows the percentage currently used. Keep an eye on it and delete unused custom fields if necessary.

Keywords

custom field, business contact capacity, exhausted, quota, maximum fields , KBA , SD-BIL-EXT , SD Billing Extensibility , SD-BIL-EXT-2CL , SD Billing Extensibility (Public Cloud) , SD-SLS-EXT , Extensibility , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions