Symptom
Manager changes are not correctly reflected in your PM forms despite the correct settings for manager transfer.
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Environment
SAP SuccessFactors Performance Management
Cause
- This enhancement allows admins to identify when forms are failing to route after a manager change has occurred caused by RBP Framework issues (Document Transfer and Change Engine issues).
- If the system detects forms are blocked for this reason, the tool will provide a mechanism to unblock forms that are stuck.
Resolution
2023 1H Update
General Availability of the Auto-Healing for Document Transfer
The Document Transfer and Change Engine issues caused by RBP refresh failures can now be fixed automatically on a daily basis.
To enable the automatic fixing, select Automatically Fix Document Transfer and Change Engine Issues under Admin Center > Performance Management Feature Settings.
When this feature is enabled for the first time, if you've also enabled Document Routing Notification or Employee Transfer Notification, users may receive a large number of email notifications about previously blocked forms that aren't relevant to them anymore.
To avoid such case, we recommend that you use Check Tool to check the number of issues before enabling this feature. You can temporarily disable the email notifications, and then enable this feature.
- Enable the check tool in Admin center > Manage permission roles > Open "permission settings" and scroll to "Check Tool" > Enable these settings:
- Go to Admin Center > Check Tool > Select the check > Click to run
Check description: if you have configured document transfer for Performance Management forms as per our guidelines, the system transfers the forms from the old manager to the new manager when there's a change to the employee's manager. When the system processes document transfer job requests, once a job request is blocked, the requests in the queue are all blocked. This check finds out how many job requests are blocked due to Document Transfer and Change Engine issues and applies Quick Fix to resolve the issue.
Check result: the check returns the number of the blocked document transfer job requests, if there are any.
Please Note before Proceeding with the Quick Fix: If the email notification 'Employee Transfer' or 'Document Routing' is enabled in the instance, it is an expected behaviour that once the Quick fix is run, the manager transfers which were stuck due to Document Transfer and Change Engine issues together with their email notification will be triggered. Before running the Quick Fix, consider disabling the email notification temporarily to avoid confusion to end users.
Should you see in the Result Column an issue/blocked forms:
- Simply click on it
- The Quick fix window will open up in a separate pop-up window
- You see the four-step process at the top of the resulting window. You are in step 1, called Found Issues.
- Choose Step 2 to proceed to Select Correction.
- The resulting window shows one or more corrections for the issue. Select the one you want and choose Step 3 to proceed to Final Approval.
- In the Final Approval step, you can opt to change your mind and not carry out the fix. If you want to proceed, choose Step 4.
- The system confirms that the fix is now running. Choose Close to complete the procedure. You can verify that the fix has run correctly after a short time by running the check again.
If you need assistance to troubleshoot Document Transfer issues when making a change in the subject's Manager, Matrix Manager or HR Rep., please refer to our Guided Answers tree about this topic.
See Also
Keywords
SF, SuccessFactors, PMGM, PM, manager change, manager transfer, DTCE, Document Transfer and Change Engine, blocked, forms, form, stuck, blocked, document, transfer, quick fix, check tool, issues, routing, PMU-17203 , KBA , csg_q , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , Problem